天下事有难易乎?为之,则难者亦易矣;不为,则易者亦难矣。人之为学有难易乎?学之,则难者亦易矣;不学,则易者亦难矣。

Centos7安装percona-xtrabackup时 报/etc/my.cnf冲突错误 解决方案

往事如烟 123次浏览 0个评论 扫描二维码

因为之前的数据库版本升级,造成percona-xtrabackup也需要升级,目前数据库为5.7.30,对应percona-xtrabackup为2.4,重新安装的过程中,遇到配置冲突的情况,如下:

[root@localhost xtrabackup]# yum install percona-xtrabackup-24
已加载插件:fastestmirror
Loading mirror speeds from cached hostfile
* base: mirrors.aliyun.com
* extras: mirrors.aliyun.com
* updates: mirrors.tuna.tsinghua.edu.cn
正在解决依赖关系
--> 正在检查事务
---> 软件包 percona-xtrabackup-24.x86_64.0.2.4.20-1.el7 将被 安装
--> 正在处理依赖关系 perl(DBD::mysql),它被软件包 percona-xtrabackup-24-2.4.20-1.el7.x86_64 需要
--> 正在检查事务
---> 软件包 perl-DBD-MySQL.x86_64.0.4.023-6.el7 将被 安装
--> 正在处理依赖关系 libmysqlclient.so.18(libmysqlclient_18)(64bit),它被软件包 perl-DBD-MySQL-4.023-6.el7.x86_64 需要
--> 正在处理依赖关系 libmysqlclient.so.18()(64bit),它被软件包 perl-DBD-MySQL-4.023-6.el7.x86_64 需要
--> 正在检查事务
---> 软件包 Percona-Server-shared-56.x86_64.0.5.6.48-rel88.0.1.el7 将被 安装
--> 解决依赖关系完成

依赖关系解决

=================================================================================================================================================
Package 架构 版本 源 大小
=================================================================================================================================================
正在安装:
percona-xtrabackup-24 x86_64 2.4.20-1.el7 percona-release-x86_64 7.6 M
为依赖而安装:
Percona-Server-shared-56 x86_64 5.6.48-rel88.0.1.el7 percona-release-x86_64 619 k
perl-DBD-MySQL x86_64 4.023-6.el7 base 140 k

事务概要
=================================================================================================================================================
安装 1 软件包 (+2 依赖软件包)

总计:8.3 M
安装大小:8.5 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
file /etc/my.cnf from install of Percona-Server-shared-56-5.6.48-rel88.0.1.el7.x86_64 conflicts with file from package mysql-community-server-5.7.30-1.el7.x86_64

错误概要
-------------

解决方案:

[root@localhost local]# rpm -ivh mysql-community-libs-compat-5.7.30-1.el7.x86_64.rpm
准备中... ################################# [100%]
正在升级/安装...
1:mysql-community-libs-compat-5.7.3################################# [100%]
然后再重新安装percona-xtrabackup即可。

注:一般出现这种情况多是版本冲突造成(之前安装过低版本的Mysql),同时再安装新版本Mysql的时候,将mysql安装源下载之后,直接使用了yum install安装,再安装percona-xtrabackup备份工具的时候,会提示错误。解决版本是将源拉取到本地之后,使用rpm安装,将相关包都下载下来,针对性的升级/安装,如图。

-rw-r--r--. 1 root root 541091840 6月 28 13:11 mysql-5.7.30-1.el7.x86_64.rpm-bundle.tar
-rw-r--r--. 1 7155 31415 26452496 3月 24 15:28 mysql-community-client-5.7.30-1.el7.x86_64.rpm
-rw-r--r--. 1 7155 31415 318688 3月 24 15:28 mysql-community-common-5.7.30-1.el7.x86_64.rpm
-rw-r--r--. 1 7155 31415 3919204 3月 24 15:28 mysql-community-devel-5.7.30-1.el7.x86_64.rpm
-rw-r--r--. 1 7155 31415 47439176 3月 24 15:28 mysql-community-embedded-5.7.30-1.el7.x86_64.rpm
-rw-r--r--. 1 7155 31415 23266228 3月 24 15:28 mysql-community-embedded-compat-5.7.30-1.el7.x86_64.rpm
-rw-r--r--. 1 7155 31415 130775552 3月 24 15:28 mysql-community-embedded-devel-5.7.30-1.el7.x86_64.rpm
-rw-r--r--. 1 7155 31415 2459484 3月 24 15:28 mysql-community-libs-5.7.30-1.el7.x86_64.rpm
-rw-r--r--. 1 7155 31415 1263752 3月 24 15:28 mysql-community-libs-compat-5.7.30-1.el7.x86_64.rpm
-rw-r--r--. 1 7155 31415 181564660 3月 24 15:29 mysql-community-server-5.7.30-1.el7.x86_64.rpm
-rw-r--r--. 1 7155 31415 123616432 3月 24 15:29 mysql-community-test-5.7.30-1.el7.x86_64.rpm

 


ITZOO版权所有丨如未注明 , 均为原创丨转载请注明来自IT乐园 ->Centos7安装percona-xtrabackup时 报/etc/my.cnf冲突错误 解决方案
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址